Thanks for the clarification Ray. I was indeed associating the dialog "Image indexing options" with the extension, and not the file type....