PassMark Logo
Home » Forum


No announcement yet.

<title> tag not picked up

  • Filter
  • Time
  • Show
Clear All
new posts

  • <title> tag not picked up

    Hi there,
    I am using the proffessional version and indexing a 150 odd pages websites.
    It is based on a few dreamweaver templates and for some reason, pages based on one of the templates display "No title" in the search results...

    Now, i have tried to compare the templates line by line and the header section of the html is exactly identical... I've actually copied it across to be sure.

    Can anyone see a reason why the title wouldn't be picked up?
    The page doesn't validate at the moment because i have had to use a clearing div within a list item, but i have also done that in the other templates and they work fine...

    Unfortunately i can give you links as this is all running on a test server for a governement website, but if anyone could give me any clues as to why that is happening i would be very grateful!!!


  • #2
    The <title> tag needs to appear within a <head> ... </head> block (if one exists) for it to be valid. So if you have a title tag outside of the head block, it would not be used.

    Perhaps you can copy+paste us the header section you are using?

    Another possibility is if you have the title within a ZOOMSTOP and ZOOMRESTART section, in which case, it would be excluded from indexing.
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine


    • #3
      Hi there.
      Yep, the title tag is in the html header, and not after a zoomstop...
      Like i said, the 2 html headers (the one that picks up the title and the one that doesn't) are the same so i would tend to think the problem is outside the header, but here is the code anyway...

      <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" >
      <!-- TemplateParam name="title" type="text" value=" " -->
      <!-- TemplateParam name="sub" type="text" value="01" -->
      <!-- TemplateParam name="page" type="text" value="01" -->
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" >
      <title>Doing Business - @@(title)@@</title>
      <link href="../css/main.css" rel="stylesheet" type="text/css" media="screen">
      <link rel="stylesheet" href="../css/sIFR-screen.css" type="text/css" media="screen">
      <link rel="stylesheet" href="../css/sIFR-print.css" type="text/css" media="print">
      <link rel="stylesheet" href="../css/main-print.css" type="text/css" media="print">
      <script src="../js/jquery.js" type="text/javascript" ></script>
      <script src="../js/sifr.js" type="text/javascript"></script>
      <script src="../js/sifr-config.js" type="text/javascript"></script>
      <script src="../js/swfobject.js" type="text/javascript"></script>
      <script src="../js/tab_config.js" type="text/javascript"></script>
      <script type="text/javascript">
      function nullFlashLoopFunction() { __flash_savedUnloadHandler = null; }
      window.onbeforeunload = nullFlashLoopFunction;



      • #4
        Nevermind, I added a zoomstop and a zoom restart just in front of the title tag and that seems to have fixed it...


        • #5
          That would imply that there must have been a ZOOMSTOP that occurs before the header.

          You shouldn't be looking at the templates. You should be looking at the resultant HTML files that are created. It's quite likely that whatever happens before or after the template is employed contains additional markup or code.
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine