PassMark Logo
Home » Forum

Announcement

Collapse
No announcement yet.

I can't get any searches to work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I can't get any searches to work

    I'm running zoom 5.1, build 1017, and I can't get any searches to work. Each time I get the error "The zoom_pageinfo.zdat file is invalid or not up-to-date. Please make sure you have uploaded all files from the same indexing session." and "Error in wordmap: page number is invalid." Here's the situation:
    • I use zoom to upload the files, in "pasv" mode
    • I deleted all the files on the webserver and pushed a complete new set
    • The error occurs whether I use the default or a custom results page
    • I'm running the .php option, on a linux server with apache
    • The search is called from the /cgi-bin folder on the webserver
    • the executable is in the /search folder


    Any help woudl be greatly appreciated !

  • #2
    V5.1 is 11 years old and no longer supported.

    We would advise upgrading to V8.

    In any case, a few quick observations:
    - You say you're using the PHP option but you also mention an "executable" and the "cgi-bin" folder. There is no executable for the PHP option. So perhaps you are using the CGI option? Possibly with a PHP wrapper script?
    - The error is almost definitely a corrupt set of index files. Check that the folder from where you are deleting the files on the web server and uploading the files to, is in fact, the same set of files you are using. It sounds to me that there is potential for confusion given that you have multiple folders ("/search" and "/cgi-bin") and confusion about the nature of the platform (CGI instead of PHP) you are using.
    --Ray
    Wrensoft Web Software
    Sydney, Australia
    Zoom Search Engine

    Comment

    Working...
    X