PassMark Logo
Home » Forum


No announcement yet.

File Name as Page Title for PDF files

  • Filter
  • Time
  • Show
Clear All
new posts

  • File Name as Page Title for PDF files

    Hello, I just upgraded from 5.1 to 6.0 and am using the same config file. In the old version all of my binary files (word, pdf, ppt etc) would display in the search results with file names as the link titles.

    Now they all say No Title.

    Is there a way I can simply use the file name as the search result link like I was able to with 5.1?

    Thanks very much, -Matt

  • #2
    Right now I see the "No Title" link and the name of the file underneathe:

    No title
    ... Crown Collection Ketchup.pdf ...
    Terms matched: 1 - Score: 38 - 01 Nov 2007 - 578k - URL: zIndex/divisions/greatlakeseast/pe-fvd/Crown%20Collection%20Ketchup.pdf

    2. No title [Literature]
    ... Crown Collection- Fancy Tomato Ketchup POS.pdf ...
    Terms matched: 1 - Score: 38 - 30 Dec 2008 - 68k - URL: zIndex/literature/Crown%20Collection%20-%20Fancy%20Tomato%20Ketchup%20POS.pdf

    3. No title [Literature]
    ... Crown Collection POS.pdf ...
    Terms matched: 1 - Score: 38 - 16 Oct 2007 - 547k - URL: zIndex/literature/Crown%20Collection%20POS.pdf

    4. No title [Selling Tools]
    ... Crown Collection- Selling Tips.pdf ...


    • #3
      I'm with Matt.

      I also upgraded and my search results uses the file's metadata 'TITLE' as the linked title.

      I would like to use the filename as the linked title.


      • #4
        Try this. Go into Zoom's configuration - Scan Options.

        Double click on each filetype and uncheck "Retrieve internal meta information".

        This should revert back to the filenames being the linked title.


        • #5
          I can't reproduce the problem here. I'm getting the filename appearing fine for PDFs with no titles specified.

          Do you have filenames enabled for indexing on the "Indexing options" panel of the Configuration tab?

          It might be a specific combination of options which is triggering this behaviour. Can you e-mail us your ZCFG configuration file? If you are indexing files offline, it may also help if you can provide us with a sample PDF that demonstrates this problem.

          sfgolfer - if you do not want to use the meta data from within the PDF/DOC/etc. file, you can change this on the "Scan options" panel, double click the file extension in question, and uncheck the option the "Retrieve internal meta information".
          Wrensoft Web Software
          Sydney, Australia
          Zoom Search Engine


          • #6
            Hi Raymond, I do have filenames enabled in the Indexing Options section.

            I just sent an e-mail with the configuration file and some sample PDFs.

            Thanks, -Matt


            • #7
              We've looked into this with Matt over e-mails, and found the cause of the problem. There is a bug with loading V5 config files into V6, where file extensions with thumbnail settings are incorrectly imported as "HTML text" file type.

              This means that the PDF files were being indexed as HTML files, and that is why they were appearing with "No title". In fact, their content was not being indexed at all.

              The quickfix to this is to simply remove the affected extensions from the "Scan options" panel of the "Configure" tab in the Indexer. Then re-add them and make sure that they are set to the correct File Type (e.g. re-add the ".pdf" extension and make sure it is set as "Acrobat document" which it should by default).

              This bug will be fixed in the next release (V6.0 build 1009).
              Wrensoft Web Software
              Sydney, Australia
              Zoom Search Engine