PassMark Logo
Home » Forum

Announcement

Collapse
No announcement yet.

Fatal error: Out of memory

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error: Out of memory

    I am getting the following error after I go to the search.php page. I go to that page, enter a term to search, and it generates this:

    Fatal error: Out of memory (allocated 33030144) (tried to allocate 257 bytes) in /homepages/37/d187788490/htdocs/Zoom Search Engine Indexer/search.php on line 1534

    I tried the following suggested in the FAQ

    1. I do not have access to php.ini, so I went to option 2.
    2. I tried the .htaccess workaround, and it caused the search.php to not even load.
    3. I put the line ini_set ( "memory_limit", "64M"); into search.php at the top (2nd line).

    It still generates the error. So, it doesn't appear that my error was precisely the same. Can you please advise?

    Regards,
    Bill

  • #2
    Fixed my own problem. I had the Limits set way too high for my site. I thought I had the file limit set at 5,000, and I had it set at 50,000. So, it obviously tried to allocate too much memory. The error on line 1354 was just coincidental. That was were I was running out of space.

    Comment


    • #3
      Glad you sort out the problem. But the limits setting in the configuration window should not affect the amount of RAM required during a search, if you set the limits in such a way so that not all of your site gets indexed.

      So as an example. If you have 1000 pages on your site. Then setting the limit to 5000 or 500000 should not alter the RAM used during a search.
      It will have a significant impact on the RAM used during indexing, but that is not the issue here.

      How many pages are on your site? If the problem comes back, you might have to contact your hosting company. Or consider looking at the CGI instead of PHP. The CGI will use much less RAM.
      Last edited by Ray; 05-19-2009, 01:22 AM.

      Comment

      Working...
      X