PassMark Logo
Home » Forum


No announcement yet.

mdash symbols not being recognized on Zoom

  • Filter
  • Time
  • Show
Clear All
new posts

  • mdash symbols not being recognized on Zoom

    I have some page titles and meta-descriptions that have an mdash in the text. Such as Non–Small. When this is used, either the actual symbol, or the html/xml numeric reference 8212; (couldn't put the full value because it kept getting converted to the actual symbol), I get a ? for where the symbol would be. If I use — then nothing is displayed and the two words are combined "nonsmall".

    What do I need to do to get Zoom to recognize one of these symbols?

  • #2
    mdash symbols not being recognized on Zoom

    We have several pieces of data that contains the mdash type symbol. I've tried using three different formats of the symbol, and Zoom has not included any of them properly. The "–" and #8212; (did not include the & at the beginning, otherwise would have been converted) result in Zoom displaying a diamond with "?" inside it for the symbol. When I use mdash, Zoom removes it completely. Example of this is the word "non–small", it will either be "non�small" or "nonsmall".

    What do I need to use to get mdash to display properly?


    • #3
      As far as I can tell, the mdash character is not suited for use in joining words like "non-small". It is used to represent a "break of thought", and a strong disconnection between the words:

      So for the clarity of searching purposes, Zoom eliminates them in the results. But the differences in behaviour with #8212 is unexpected. We'll look into it.
      Wrensoft Web Software
      Sydney, Australia
      Zoom Search Engine


      • #4
        I was able to get this to work. Found that Encoding and character sets in the Languages tab was set to windows-1252 and not UTF-8. Once I switched this to User Unicode (UTF-8 encoding) the symbol for the mdash ("–") worked fine.