PassMark Logo
Home » Forum

Announcement

Collapse
No announcement yet.

autocomplete not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • autocomplete not working

    Hi,

    I'm testing V7.1 with Drupal and having issues with autocomplete feature.

    When I start typing, autocomplete box appears. However instead of displaying suggestions, this box loads the 404 not found page webpage within it (just like an iframe).

    When I have a look at the browser console it says, Failed to load resource: the server responded with a status of 404 (Not Found)

    Can I please the reason for it and if anyone had this issue before?

    Thanks
    Attached Files

  • #2
    Hi,

    This was due to search.php having inside 'zoom' folder. I have now placed all zoom related files in root folder. Now there aren't any errors showing up, but no autocomplete box is showing either.

    Should I wait for some terms to be added to popular searches for this function to work?

    Comment


    • #3
      What options did you select in the Auto-complete configuration window in Zoom?
      (e.g. are you using page titles for word suggestions?)

      Comment


      • #4
        Hi. Sorry for the late reply.

        I have only selected 'Enable autocomplete'

        Comment


        • #5
          Thanks it worked when page titles were enabled. Please advice how I should go about including PDF files to autocomplete.

          Comment


          • #6
            The Titles of PDF files (found within Document Properties in Acrobat Reader) would be utilised for autocomplete when this option is enabled. Make sure your PDF files have meaningful titles in these fields.

            Let us know if that's not what you mean.
            --Ray
            Wrensoft Web Software
            Sydney, Australia
            Zoom Search Engine

            Comment


            • #7
              Thanks for your answer Ray. What if a user types 'planning' in autocomplete search box and a PDF has this word within the content of the file (not in PDF title)? Is zoom search still smart enough to index it to autocomplete suggestions?

              Comment


              • #8
                Under "Configure"->"Autocomplete" in the Indexer, you'll see that you can configure where Zoom extracts words for autocomplete from.

                It is not practical for Zoom to use ALL words that has been indexed as part of the autocomplete. The end user would literally have to scroll through every an entire dictionary's worth of words starting with "p" for example.

                So in this configuration, you can ask Zoom to use words found in the document title, the meta keywords or description (also fields in PDF documents) OR use the top x words searched by people from the Statistics Log.

                Setting up the latter is further explained in the Users Guide.
                --Ray
                Wrensoft Web Software
                Sydney, Australia
                Zoom Search Engine

                Comment


                • #9
                  Thanks for your answer. In autocomplete box, I would like to style PDFs differently. An example would be to have a pdf icon next to the result.

                  Click image for larger version

Name:	results.png
Views:	17
Size:	9.8 KB
ID:	35788 )

                  Is there a way to distinguish pdf files in autocomplete box? I believe Zoom search won't be able to do this because once the indexing is done for document title, it won't keep track of whether it is a .pdf, .doc or a html page.

                  Comment

                  Working...
                  X